Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using WinSSHD on my server.

I can connect locally on the server via telnet&management studio, specificing the port 1433. I have allowed remote connections.

I can telnet from my local computer at localhost 14333(local port) and get the correct telnet prompt up.

But when I try to connect via management studio locally to localhost,14333 I get

TITLE: Connect to Server

Cannot connect to localhost,14333.


A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.) (Microsoft SQL Server, Error: 10061)

What a classic error message.

Is there any special reason this isn't working? Considering telnet is working via ssh, I thought I was home and dry.

share|improve this question
If it were me, I would try to take the shenanigans out of it. Namely, you've got SSH sitting between you and the SQL process. See if you can connect with SSMS on 14333. That the error message says "the target machine actively refused it" is usually an indication to me that I have the wrong port. Also, what are you trying to accomplish with ssh? You can secure a connection with an SSL certificate installed on the server side. – Ben Thul Mar 26 '12 at 2:53
up vote 0 down vote accepted

something else is at play here. I have successful got management studio to work over ssh, even with winsshd without issue.

Is SQL Server running as a default instance? May we see the port forwarding settings your using in your ssh/putty client?

share|improve this answer

Although this isn't the real answer, I found that when I used It worked correctly.

I had to use ip, not hostname, but,14333 worked.

I'm guessing it's some kind of putty-> winsshd issue?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.