Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

No matter how I test using different value of Accept-Encoding, it always returned as gzip.

curl -I -H  'Accept-Encoding: gzip' http://www.example.com
Content-Encoding: gzip


curl -I -H  'Accept-Encoding: deflate' http://www.example.com
Content-Encoding: gzip

So how to force deflate?

share|improve this question
6  
You probably don't want to use deflate. stackoverflow.com/questions/388595/… –  sciurus Mar 30 '12 at 4:14
    
Do you have mod_deflate enabled and configured? httpd.apache.org/docs/2.3/mod/mod_deflate.html –  Eli Sand Apr 4 '12 at 0:54

1 Answer 1

up vote 0 down vote accepted

You can't. mod_deflate only ever responds with Content-Encoding: gzip.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.