Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the problem that I cannot connect to a Windows 2008 R2 (SP1) server via RDP using my Mac. The error Message I get is the following: “You were disconnected from the Windows-based computer because of problems during the licensing protocol”

From asking Mr. Google I tried the proposed solution to delete some cached files, but it didn’t resolve the problem.

The strange thing is that to other S servers running Windows 2008 R2 (SP1) on the same Network I can connect.

I checked the configuration on the server and noticed that under Roles -> Remote Desktop Services -> RD Session Host Configuration it says under Connection Type: “Microsoft RDP 7.1”. On other server where I can connect it says “Microsoft RDP 6.1”.

Could that be the reason?

The Mac I use has Lion 10.7.3 installed

Bye, Martin

share|improve this question
    
Are you using the 1.0.3 or 2.1.1 client? You might be having issues using the older client. Just a thought. microsoft.com/mac/downloads –  MikeAWood Mar 27 '12 at 1:09
    
Check that your server is registered with a correct RDP license server –  Mathieu Chateau Apr 2 '12 at 19:47
    
@Mike I'm using the newer one 2.1.1. –  mazebuhu Apr 3 '12 at 13:25
    
@MathieuChateau It is connected to a correct RDP license server I double checked that. –  mazebuhu Apr 3 '12 at 13:26

3 Answers 3

up vote 2 down vote accepted

This is a known issue. You will have to wait for the hotfix from either MS or apple. Use CORD the open source RDP client. I manage several terminal servers and some macs cannot connect. MS has acknowledged the issue.

share|improve this answer
    
Ok got in contact with MS support and they told me exactly the same. We have to wait until they release the hotfix. –  mazebuhu Oct 7 '13 at 10:34

Use the latest rdp client 2.1.2

https://dl.dropbox.com/u/18309066/rdc_2.1.2_120917_release_enu_ship_clean_standard_retail_redlab_120917-apex-build-XS26-.dmg

share|improve this answer
    
just tried this and it works fine. checks clean on virustotal in case anyone is concerned. virustotal.com/en/file/… –  starfry Jun 8 '13 at 22:21

Sorry - have this Trouble today RPD 7.1 in a full patched 2008R2 Server an NO official RDC Pack higher than 2.1.1

So you can use CoRD (http://cord.sourceforge.net/) We´ve tried and it worked fine for "normal" user RDP Connection

Greetings from Hamburg/Germany Lutz

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.