Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My domain(www.site.com) is hosted on a webserver running cPanel. My mails are handled by my ISP's server. To retrieve my mails, I use the following setting given by my ISP:

pop3.isp.com smtp.isp.com

On my cPanel, I have added MX records for both the smtp.isp.com and pop3.isp.com, so that mails will be handled by my ISP. The smtp.isp.com is on priority 0, and pop3.isp.com on priority 4

However, when I send mail to my email account, I get a reply saying "Sender address rejected: Unauthorized relay (state 14).

What am I doing wrong?

share|improve this question
    
Better to name your real domain - it's safe. MX to smtp.isp.com is (most likely) delirium –  Lazy Badger Mar 26 '12 at 17:28

6 Answers 6

up vote 3 down vote accepted

You need to contact your ISP.

The servers used by your mail user agent (pop3.isp.com and smtp.isp.com) have nothing to do with your MX record. The MX record may need to point to something else entirely.

For example, GMail uses this for the MX:

$ host -t mx gmail.com
gmail.com mail is handled by 10 alt1.gmail-smtp-in.l.google.com.
gmail.com mail is handled by 20 alt2.gmail-smtp-in.l.google.com.
gmail.com mail is handled by 30 alt3.gmail-smtp-in.l.google.com.
gmail.com mail is handled by 40 alt4.gmail-smtp-in.l.google.com.
gmail.com mail is handled by 5 gmail-smtp-in.l.google.com.

Whereas the mail user agent configuration would use imap.googlemail.com for the incoming and smtp.googlemail.com for the outgoing.

Your ISP will have instructions on how to set things up properly. We can't tell you anything else beyond that, since we don't know how your ISP does things.

share|improve this answer

It sounds like your mail server is not configured to know that it should handle emails for your domain. This setting is known as the local domains in Postfix and probably something similar in other MTAs.

Since your hosting provider is configuring the MTA for you, you should give them the above error message along with the domain you are sending to.

share|improve this answer

The "Unauthorized relay" error means that your ISP's mail server isn't configured to accept mail for *@mysite.com.

Your ISP is configured to handle mail for *@isp.com, and it won't accept email for any other addresses. Even if it did accept the email, it knows your email address as something like damchey@isp.com - how would it know where to send emails to support@mysite.com?

Email is hosted just like websites are. Your ISP will not automatically host mail for you. Some ISPs will, either for free or for a small charge, but it's something you need to setup with them. If you have already set that up with them, you need to contact your ISP's tech support to give you the correct MX records to use.

I prefer to stay away from having my ISP host my email - it makes it harder to change ISPs even if something better comes along. Instead you should check if your web hosting provider also does email, or sign up for something like Google Apps for your Domain, which is free for up to 10 users. No matter who you get to host your email, they should give you the correct servers to put in the MX records, as well as what POP3 and SMTP servers to use in your mail client.

share|improve this answer

Could you check the domain name used in your destination emails ? Maybe you are not sending mails to you domain and then, they are rejected by your ISP.

share|improve this answer
    
Tried sending mails to my domain (info@site.com, and this account exists on the ISP's mail system) from my hotmail/gmail/yahoo accounts, and all get the same error. Mails are not delivered. Was wondering what actually do I need to insert in the MX record field in my cPanel. Do I use smtp or the pop3 address of my ISP. pop3 and smtp are on different IP addresses. –  NetworkNewbie Mar 26 '12 at 8:05

Solved my problem finally. Appears that the smtp.isp.com was wrong. They had a different hostname for their smtp server. Found out by using pingability.com on other sites which had mails hosted on this ISP. Happened cause ISP had no information to give me when asked.

share|improve this answer
    
Hmm. Maybe consider a different provider, one that has better documentation? –  cjc Mar 26 '12 at 20:05

smtp.isp.com is not configured to relay emails from port 25. So you must change your mail client settings to use port 587 to submit email or ask your ISP's helpdesk how to setup your mail clients to send authenticated mail via smtp.isp.com

share|improve this answer
    
Umm, this is a question about MX configuration, not mail user agent configuration. –  cjc Mar 26 '12 at 12:06
    
@cjc #!E$?! That's what you get when you read diagonally ... In that case the problem is that smtp.isp.com and pop3.isp.com do not know how to relay incoming mail for his domain. –  adamo Mar 26 '12 at 12:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.