Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to get RabbitMQ working with SSL on a couple of Gentoo servers. I get the following error in /var/log/rabbitmq/rabbit@...log when I try to connect to the management console using https:

SSL: certify: ssl_connection.erl:1641:Fatal error: bad certificate

I followed the instructions here: http://www.rabbitmq.com/ssl.html

The annoying thing is that I have 2 cloned servers and it is working on one and not the other. As far as I can tell the machines are configured identically. I wrote a script to generate the certs etc. and have run it on both.

I am not using client certificates.

Anyone know how I can figure out whats wrong with my certificate(s)?

I am using Erlang 15.2, RabbitMQ 2.7.9, OpenSSL 0.9.8k.

share|improve this question

1 Answer 1

http://www.rabbitmq.com/troubleshooting-ssl.html is a better link. I'm stuck at broker listening ... it's not reading my config file. Okay, I got past that (it must be called /etc/rabbitmq/rabbitmq.config and nothing else):

Here's my script to generate CA and SSL certificates for rabbitmq and friends -- http://www.mcgill.org.za/stuff/software/instant-certificate-authority-script Generate a client certificate and see if things work out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.