Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure TFS 2010 reporting and have come accross the following error:

Failed to add Domain\Development account to the TfsWarehouseDataReader role on the Tfs_Warehouse relational database

I have set up reporting service on the machine and have used the NETWORK SERVICE as the service account and the database login and seems to be working OK.

In the Analysis Services and Reports tabs I have specified our domain admin for access to the datastore.

Looking at the database it created Domina\Development as a group (which I assume is correct as this is a group on the domain) but the TfsWarehouseDataReader is not ticked. I manually tick this and try finishing the configuration again and I get the same error.

Been looking all over google and can not find anything, can anyopne help?

share|improve this question

1 Answer 1

Did you grant the account "log on locally" permissions?

From the MSDN page on account requirements for the report reader: "You must specify a user account that has the Allow log on locally permission."

http://msdn.microsoft.com/en-us/library/dd578625.aspx

share|improve this answer
    
When you say account do you mean the Domain\Development? As this is a group –  MrsNezbit Mar 27 '12 at 7:15
    
No, the account is the report reader account. You need to give a domain account the log on locally permission. During tfs install you are prompted for this account. Not sure how its handled during "add reports" but you should make sure the account you used has the permissions it needs. –  Tim Elhajj Apr 20 '12 at 13:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.