Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Nothing makes you feel dumber than disabling a NIC while in RDP, but here I am :) I have mounted the volume on another instance and tried editing the registry. I have tried enabling auto logon and using runonce to run a netsh command to enable the NIC, but that does not work. I read something about enabling the NIC through the registry directly, but have had no luck in doing this.

Has anyone dealt with this type of issue? I'm going nuts!

Thank you!

share|improve this question
Take a look at… – Grant Mar 26 '12 at 17:25
@Grant - Tried this already. Does not seem to work for some reason. – Elad Lachmi Mar 26 '12 at 17:36
up vote 2 down vote accepted

Create AMI from that instance. Launch new instance from that AMI but in VPC, there you will have option to add another NIC. Access through new NIC.

share|improve this answer
This would work, but I ended up just launching a new instance, mounting the old drive and copying the files over manually. – Elad Lachmi Mar 27 '12 at 13:08

If you can, get the AWS instance to have another MAC address. This should cause Windows inside it to think it a new interface, and it should use DHCP by default as well.

share|improve this answer
It looks like AWS allocates a new MAC each time the instance is stopped and re-launched. This does not seem to help. – Elad Lachmi Mar 26 '12 at 17:12

Attach an additional Elastic Network Interface to your instance. If you are in a VPC, make sure to provision in the same AZ and VPC as your instance, ensure the security group you select lets you RDP in. Once the ENI is attached, you will have an additional internal IP, this will allow you to RDP in via this new ENI. Then you can enable the previously 'disabled' ENI or NIC and then detach this new ENI.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.