Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have SQL Server 2008 R2 (RTM) running on a Windows Server 2008 R2 (SP1) box. This instance exists primarily to run SSRS in SharePoint integrated mode.

When I open SQL Server Configuration Manager, by default, "SQL Server Services" is selected. Only "SQL Server Reporting Services (SSRS)" and "SQL Server Browser" are listed. Not listed are "SQL Server (SSRS)" and "SQL Server Agent (SSRS)". The instance is named "SSRS".

I can see and control all the services in Server Manager.

I found this kb article referencing SQL Server 2005 which seemed promising, and followed all steps it contains (copied here - note that I added a "4.a" that I thought was missing from the article)

  1. Open a session in the server that has SQL Server installed. Open the session by using a Windows account that is part of the Domain Administrators group.
  2. Download and then install the Group Policy Management Console if you do not already have the console installed.
  3. Open the Group Policy Managment Console. Then, select the organizational unit where SQL Server is located.
  4. Create a new Group Policy object or edit the existing Group Policy object that is associated with this organizational unit. To edit the existing Group Policy object, right-click Policy Object, and then select Edit. A new Group Policy Object Editor Microsoft Management Console (MMC) appears. 4.a - Navigate to "Computer Configuration \ Policies \ Windows Settings \ Security Settings \ System Services"
  5. In the Service Name column, double-click SQL Server (Instance_Name).
  6. In the SQL Server (Instance_Name) Properties dialog box, click to select the Define this policy setting check box, select the appropriate startup mode, and then click Edit Security.
  7. In the Security for SQL Server (Instance_Name) dialog box, click NETWORK SERVICE under Group or user names. Note If the NETWORK SERVICE account is not listed, add the account before you perform this step.
  8. Under Permissions for NETWORK SERVICE, click to select the Read check box in the Allow column, and then click OK.
  9. Repeat steps 5 through 9 to add the READ permission to the NETWORK SERVICE account for other SQL Server 2005 services.

I performed the actions above for the services "SQL Server (SSRS)" and "SQL Server Agent (SSRS)". I applied the group policy via "gupdate /force" and then re-opened SQL configuration manager. Nothing changed, only "SQL Server Reporting Services (SSRS)" and "SQL Server Browser" are listed.

How do I get "SQL Server (SSRS)" and "SQL Server Agent (SSRS)" to appear in SQL Server Configuration Manager?

EDIT: Out of curiousity i ran Resultant Set of Policy on the server and I see that in "System Services" the "Startup" value is defined but the "Permission" column is not.

EDIT2: The "Network Service" permissions do show up in RSoP.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.