Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a windows 2008 server running with FTP 7 on IIS 7.

I have it configured to connect as it is out of the box, with a particular user (lets say john) with read/write access.

When I use my FileZilla client software, I can connect to the server as john just fine. No problems at all. However, when I try to connect using Windows Explorer or using the cmd prompt I get stone walled, saying "Login failed". My client machine is Windows Vista Ultimate.

Does anyone know what might be causing this?

share|improve this question
    
What do you see in the IIS logs on the server? Show us what logs are entered when the login fails and we'll be better able to diagnose this. –  Christopher Cashell Jul 8 '09 at 17:46
    
@Christopher I couldn't find any logs, but I did find out what the problem was I think. I've posted an answer to detail the solution. –  Joseph Jul 13 '09 at 13:02

5 Answers 5

up vote 9 down vote accepted

I just want to say that all the answers were helpful to me.

In the end, however, the solution I came to was actually quite simple, and I should have thought of it sooner.

I realized that I had not restarted the server after I installed FTP 7. I didn't actually think this was required, but after restarting the box and seeing windows explorer and the ftp cmd working, I came to the conclusion that it must be necessary to some extent.

So, for anyone having the same issue that I've had, make sure to restart the box after you've installed FTP 7.

share|improve this answer
2  
Fixed it for me - thanks. I wonder why windows server doesn't inform you?! –  UpTheCreek Feb 3 '11 at 12:35
    
I would have never thought of rebooting if I hadn't found this question. –  Bogdacutu Sep 7 '12 at 11:44
    
I had the same problem with my IIS 7.5 FTP on Windows 7. It works locally but could not be accessed from other computer. A restart solves the problem. –  Rosdi May 12 '13 at 2:32

Are you telling Explorer / ftp.exe to connect with a certain username, rather than 'Anonymous'?

What errors show up in the IIS log?

share|improve this answer
    
I'm prompted for a user name, which I input, and then a password, which I input, and then it says "Login Failed" (for ftp.exe). Windows Explorer just brings up the authentication dialog over and over again until I finally hit cancel. I'm definitely not logging in as 'Anonymous', though. –  Joseph Jul 8 '09 at 12:35

Make sure you are including a username in your requests. For example, when you connect with Windows Explorer, enter the URL as something like:

ftp://USERNAME@ftp.your-ftp-host.com

Alternately, you can usually also specify the password on the line like:

ftp://USERNAME:PASSWORD@ftp.your-ftp-host.com

share|improve this answer
    
Is this a requirement even if Windows Explorer prompts me for my user name and pasword if I don't include it in the request? I'm going to try this and see if it works, but I would think that is very odd that I have to include authentication in my request rather than specifying it using the authentication dialog. –  Joseph Jul 8 '09 at 12:36
    
If you're getting prompted for it, then this probably isn't required. I was concerned that you it was trying to authenticate as anonymous/ftp and that was failing. –  Christopher Cashell Jul 8 '09 at 17:45

If the other answers fail to solve your problem and there's a firewall in between you and the ftp server the firewall could be causing problems with passive mode ftp connections. Which is what explorer uses by default. You can change explorer to use active connections (also called port mode) with the following steps.

  1. Open Internet Explorer
  2. Tools->Internet Options
  3. Goto the advanced tab
  4. Under Browsing, click to clear the Enable folder view for FTP sites check box.
  5. Click to select the Use Passive FTP (for firewall and DSL modem compatibility) check box.
share|improve this answer
    
Based on the error you're getting I think this is unlikely but I've seen Windows give some odd error messages in the past. –  3dinfluence Jul 8 '09 at 0:01

I had the same issue, and the answers mentioned above didn't work. Then I noticed that the default application pool didn't run. Since I only needed FTP, I only installed the FTP services in Win2008. The solution for me was to install the Webserver-components (basic webserver functionality) in the server functions. After this, I could start the default application pool (no restart required ;-) and the FTP login worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.