Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently i have installing apache 2.2.21 from the source for testing purpose. After doing clean installation of apache i want to patch it with the patches provided here: http://www.apache.org/dist/httpd/patches/

Anyway when i put the patch command as mention in the page it show this result:

File to patch: CVE-2011-3368.patch 1 out of 1 hunk FAILED -- saving rejects to file CVE-2011-3368.patch.rej

Is there something wrong with my patch?If not,how could i verified that the patch has been implemented or not?

share|improve this question
    
Have you tried reading the patch and related files? –  Ignacio Vazquez-Abrams Mar 27 '12 at 3:54
    
yeah,i had read the documentation but still not quite understand on how the patch works. –  newbie.my Mar 27 '12 at 4:19
    
I already solved the problems! Actually after checking through the patches it contain the path that it will change.After moving the patches to the designated path, i run the patch command: patch -s < CVE-2011-3368.patch and it works! –  newbie.my Mar 27 '12 at 9:42
1  
Hi - welcome to Server Fault. It's not necessary to add "Solved" to your title. When you can add your own answer and then accept that to show that the problem is solved. In the meantime your comment should suffice. –  ChrisF Mar 27 '12 at 9:49
add comment

1 Answer

This problem was solved by moving the patches to the correct location before running the command

patch -s < CVE-2011-3368.patch
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.