Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

im lost. I have tried everything and I cannot solve this.

I have an older server running XenServer with Supermicro board X8STi-F, it has an integrated IPMI which I share on LAN 1 and it always worked well until I needed to have the build in network mounting for OS, which my IPMI interface did not had because it was running something very old like firmware version 1.0

So I upgraded the IPMI firmware and I lost ping connection in the process to the IPMI IP, which is normal I think as I was sharing the IPMI port with LAN1. It was when it the upgrade process was at 99%.

The same minute I lost network access and ping to the IPMI card.

So I installed the IPMICFG from Supermicro plus IPMItools.

The firmware was upgraded and it also works. When I was upgrading the readme instructed NOT to maintain settings from this version so settings where reset to default. After setting all of them again, including in the BIOS I cannot get ping back.

The IPMI works, I can issue commands both with IPMItools and the IPMICFG tools from Supermicro. Everything works, even raw commands, sensors. All except the network.

I tried absolutely everything, setting it to onboard with:

#ipmitool raw 0x30 0x70 0x0c 1 1 1

Setting the IP, MAC, Gateway, etc. The only think which I was not sure was the MAC, after the upgrade the MAC on the IPMI was all to

But the MAC in the BIOS as told by my remote support was a consecutive number to LAN 1 and LAN 2. So if LAN 1 was ending with C4, and LAN 2 to C5 (which I can see in the OS), the C6 could only be from the IPMI card. Its also set then correctly.

Everything is set and I get data from commands but no matter what I do I cannot ping it, this means no web console or use it at all.

This issue would not be so critical but the fact that I need to upgrade to XenServer 6 to be able to have CentOS 6 support in VM templates. And I can´t because without IPMI I will not be able to remotely mount the ISO and do the upgrade.

Im over a month with this issue and I cannot find where or how the issue is. From the DC side everything was tested already, including all tricks of leaving the server without power cord for 3 minutes, so it detects the correct settings. I mean, im left without tricks. Usually the problem would tell me its set forced to dedicated, but I checked everything, and it costs me hand on server each time the DC checks the BIOS or does something. I have complete access to the OS and can run the commands via IPMItools.

I also reflashed the IPMI firmware several times already.

The IPMI IP will not respond, not even connecting a cable directly to it, but the port works. So its something in the setting or software which is failing.

# ipmitool sdr  
CPU Temp         | 0 unspecified     | ok
System Temp      | 38 degrees C      | ok
DIMM1A Temp      | 27 degrees C      | ok
DIMM1B Temp      | 29 degrees C      | ok
DIMM2A Temp      | 26 degrees C      | ok
DIMM2B Temp      | 27 degrees C      | ok
DIMM3A Temp      | 26 degrees C      | ok
DIMM3B Temp      | 26 degrees C      | ok
CPU Vcore        | 0.96 Volts        | ok
CPU DIMM         | 1.53 Volts        | ok
+5V              | 5.09 Volts        | ok
+12V             | 11.87 Volts       | ok
-12V             | -12.00 Volts      | ok
+3.3V            | 3.19 Volts        | ok
+3.3VSB          | 3.24 Volts        | ok
VBAT             | 3.26 Volts        | ok
Fan1             | no reading        | ns
Fan2             | 3645 RPM          | ok
Fan3             | no reading        | ns
Fan4             | 3915 RPM          | ok
Fan5             | no reading        | ns
Fan6             | no reading        | ns
Chassis Intru    | 0 unspecified     | nc
PS Status        | 0 unspecified     | ok

Is there someone expert on this field which can solve this misery? I'm willing to do everything to resolve this issue.

share|improve this question
Did you solve this? I might have the same problem.… – Jesper Grann Laursen Apr 15 '13 at 6:17
I have fixed a similar issue by removing power to the ipmi for 30 seconds and then applying power again. – user178753 Jun 21 '13 at 18:39
What is the output of ipmitool lan print 1? – Dennis Williamson Aug 31 '13 at 20:10

From where are you trying to ping the card - if it is from the host itself, different rules apply in case the NIC has gone to Shared mode..

May I suggest you check Supermicro's FAQ database, there is a lot on IPMI card behaviour in there...

share|improve this answer

Like rachandboneman already stated, it might be important from which host you are trying to reach the IPMI module.

As far as my experiences with SuperMicro IPMI modules are concerned, I found out that you can not reach the IPMI module via network from the same server. You therefore have to ping the IPMI module from another host since the remote management module uses a shared connection with the "normal" server.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.