Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm testing a 32-bits ISAPI extension on a web-server with IIS 7.5 and get strange behaviour in some cases. At a certain point in the web application, a URL serves a large (a few MB) JPEG file directly to the client (Content-type: image/jpeg).

The image gets transmitted for a first part, but the response seems to halt for an unknown reason. Nothing happens until, from another browser, another request comes in and gets handled. Then another few KB of the image gets sent to the client. Only if I fire a couple of small requests from the other browser I get the entire image and the response completes.

The ISAPI extension is configured as a wildcard mapping, no caching is configured. The application pool has the 32-bits setting enabled, and runs with a domain account as identity (to access things on the back-end). I tried switching 'Enable cache' and 'Enable kernel caching' off. I tried on IIS 5.1 and 6.0 and there it works as expected.

Is there another configuration setting I am overlooking, or did I stumble upon a bug in IIS 7.5?

share|improve this question
    
Any further detail on how it's being sent, what the extension is, etc? –  TristanK Mar 27 '12 at 11:32
    
It's an extension that provides access to a gallery of photo's stored on the internal storage solution. The data is sent over the ECB's WriteClient function. –  Stijn Sanders Mar 27 '12 at 12:39

1 Answer 1

up vote 1 down vote accepted

Guess:

ISAPI extensions that send long responses to the client may not transmit any output in Internet Information Services 7.0 until the session is closed http://support.microsoft.com/kb/946086

share|improve this answer
    
Thank you, for a moment I thought it was (temporarily) fixed by disabling the HttpCacheModule, but this is the real fix indeed. xxm.svn.sourceforge.net/viewvc/… –  Stijn Sanders Mar 29 '12 at 19:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.