Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I moved our web hosting to Amazon EC2. At first everything was working well. In the last few days I have been getting this error:

The requested name is valid, but no data of the requested type was found

This seems to be a DNS issue, and I have no idea how to deal with this.

Has anyone seen this error from an EC2 instance?

More Info: It is a windows instance. The look up is a reverse look up of the current machine. The callstack looks like this:

     SocketException (0x2afc): The requested name is valid, but no data of the requested type was found]   
    System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6) +7987115   
System.Net.Dns.GetHostAddresses(String hostNameOrAddress) +544   
ClientDependency.Core.UriExtensions.IsLocalUri(Uri uri) +184
share|improve this question
    
Where and in what context are you getting this error? Do you know what name is being requested? If you think it is a DNS issue, what is your server's DNS configuration? Would you care to tell us whether this is a Linux instance or a Windows instance? Unfortunately, your question in its current/original form is not answerable. –  Skyhawk Mar 30 '12 at 8:01
    
Added more info. Sorry, I was thinking maybe this is a known issue with AWS. This worked on a VPS hosted with GoDaddy for a year without error, before moveing to AWS. –  Elad Lachmi Apr 2 '12 at 1:10
    
Possible duplicate: stackoverflow.com/questions/9426063/… –  Skyhawk Apr 2 '12 at 1:43
    
@MilesErickson - 1. Not really. 2. This is a system issue, not a c# issue, since it started only after moving to AWS, and with no code changes. 3. Last, but not least: There is no answer there :) –  Elad Lachmi Apr 2 '12 at 1:53
    
If it worked at first, then I sincerely doubt that this is directly related to your move to EC2. The link to the duplicate question was for future reference/moderation purposes, not because I thought it would be immediately helpful. –  Skyhawk Apr 2 '12 at 2:03
add comment

1 Answer

up vote 2 down vote accepted
+50

This is a Windows issue that is not specific to Amazon EC2.

Others who have experienced this error message have reported resolving it in the following ways:

  • Simply rebooting the server
  • Resetting the Windows TCP/IP stack with netsh int ip reset
  • Modifying the ASP.NET application's source code: Example 1, Example 2
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.