Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having DELL laptop with Windows 7 professional, IIS 7.5.

I have installed .Net framework 2.0, 3.5, 4.0.

Some of my old asp.net applications are built on framework 2.0 and 3.5. I tried configuring the application in IIS but it is not showing me framework settings. The only thing i can set is the application pool but it is showing only 4.0.

Anyhow, i configured the application for 4.0. When i try to access the application i am getting error message in the browser.

Software Genius Inc

When i try to execute it from Visual Studio 2008 i am getting the following error.

Software Genius Inc

Can anybody help me out resolve this issue.

Thanks for sharing your wisdom.

share|improve this question

2 Answers 2

Try changing the application pool to run in classic mode instead if integrated, for the affected applications.

You should be able to run a web application with a .Net 2.0/3.5 configured web.config file in IIS 7.5 using this setting

share|improve this answer

For one thing, you should re-register .NET 2.0 and 3.5 for IIS (in the select box of the application pool settings the only choices will be 2.0 and 4.0 - and the non managed setting - because .NET 3.x is basically the "same" as 2.0 with quite a few libraries added, but 2.0 should definitely be there).

You can try

C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i -enable

or google "register .net 2.0 iis 7.5" or "aspnet_regiis" directly - this will give you a lot of information.

Secondly, your application is not running under 4.0 because the web.config is not configured properly (it says so in your error description). You have a duplicate section somewhere (it's too small to read for my eyes). Check this and make sure the web.config is valid.

share|improve this answer
    
Thanks Olaf for your quick reply. First thing, the applications which i am trying to execute on IIS 7.5 are already tested for IIS 6. I just ported it to IIS 7.5. Secondly, i tried registering the .Net 2.0, 3.5 as you given but didn't solve the problem. –  IrfanRaza Mar 27 '12 at 18:59
    
@IrfanRaza: did you try fixing the web.config as I described in my answer? –  Olaf Mar 28 '12 at 8:31
    
yes i did but still same issue. –  IrfanRaza Mar 29 '12 at 12:16
    
Can you post your web.config? –  Olaf Mar 29 '12 at 12:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.