Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have Exchange 07 with all clients on Outlook 07 (some XP some 7). Once in a while a user who's had cached credentials will suddenly be asked to enter their password. The username will be presented as "user.name" or "exchange\user.name" but never the correct "domain\user.name" and they won't be able to login unless they explicitly specify the proper domain as part of the username.

Anybody have any ideas what would cause this behavior? It seems to crop up rarely, but is frustrating for users, particularly at remote sites. Thanks,

share|improve this question

3 Answers 3

up vote 3 down vote accepted

The impression I get, although I've found no evidence to back this up, is that there's a fundamental bug in all recent versions of Outlook (2003, 2007, 2010) where the username field in the Exchange login dialog is populated with EXCHANGE-SERVER\username instead of DOMAIN\username, preventing the user from successfully logging in.

Sometimes it will start out with username, and replace it with EXCHANGE-SERVER\username if the first login attempt failed, for example a typo.

It certainly happens with domains with a dedicated Exchange server; I wish I could remember categorically whether I've seen this with SBS 2003/2008/2011 as well, but I can't unfortunately. I just know that when a user is being prompted by Outlook to enter credentials and reconnect to Exchange (and this does include password changes, as was mentioned), Outlook tends to write MAIL-SERVER\username and not DOMAIN\username into that field.

(If Outlook could actuall get the username right, password changes wouldn't be such a hassle.)

share|improve this answer

Have seen this after a user changes their password and a Domain Controller at a branch site has not replicated. Do you have multiple DCs?

share|improve this answer
    
One DC, password hasn't changed. –  Josh Mar 27 '12 at 14:57

If your domain name in AD doesn't match the email's domain name you will be prompted to explicitly enter domain/username combinations.

E.G. bob@domain.local vs. bob@domain.com

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.