Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a named instance of SQL Server 2008 R2. When I attempt to connect to the named instance I get the following error (if the browser service is set to logon as anything other than Local System):

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

When I change the account I use SQL Server Configuration Manager and have tried Local Service, Network Service, and a local account. I made sure the local account was a member of the "SQLServer2005SQLBrowserUser$MachineName" local group and has all the rights specified here.

How can I use a local account as the log on account for the SQL Browser service?

share|improve this question

2 Answers 2

The account running the SQL Browser service must have read permissions on the following key: HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\ (for a named instance, replace MSSQLSERVER with instance name). Thanks to squillman for putting me on the right track.

share|improve this answer

SQL Browser reads instance network configuration information from the registry; maybe the permissions there got messed up. Verify that the account you're using has access to read info underneath the following key:

HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQLServer\
share|improve this answer
    
For whatever reason, your method didn't work, but granting read on the parent (HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\ in your example) did work. Also, this key will be different for a named instance - replace MSSQL10_50.MSSQLSERVER with MSSQL10_50.INSTANCENAME) –  Chloraphil Mar 29 '12 at 18:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.