Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to simulate two different computers on one box, using the macvlan module (which is awesome, by the way) but I have one small problem; When I create the macvlan Ubuntu 11.10 very helpfully starts broadcasting its hostname on both interfaces, creating an amazing amount of confusion for everything that deals with hostnames.

Does anyone know how to stop ubuntu from advertising its hostname on a certain interface? Thanks!

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

You don't explain in what manner your system is broadcasting its hostname. If you're seeing it show up via multicast DNS, you may want to look to the "avahi" package, which is often used under Linux to broadcast multicast dns notifications on the local network. I don't know the exact package name under Ubuntu, but you can probably find the control script somewhere in /etc/rc.d.

You can safely just stop the avahi server and disable the service, unless you're relying on this for service discovery on your local network.

share|improve this answer
    
Awesome. That's exactly what I meant. Avahi was indeed the culprit, and there is an /etc/avahi/avahi-daemon.conf with an "allow-interfaces" and "deny-interfaces" area. –  staticfloat Mar 27 '12 at 22:33
    
Additionally, anybody playing around with macvlan stuff should be aware of the "arp flux" problem; if your ssh sessions are randomly dropping, then I suggest you look here: serverfault.com/questions/207480/… and then here: linux-ip.net/html/ether-arp.html –  staticfloat Mar 28 '12 at 5:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.