Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to create a netboot installer that allows installing various versions of linux. My TFTP server is dnsmasq from debian wheezy. I've got debian, ubuntu, and fedora working fine, but I'm having trouble with opensuse. Here's a snippet of my pxelinux config (using pxelinux 4.05 from ubuntu 12.04):

label openSUSE-11.4-i386
menu label openSUSE 11.4 i386
menu indent 2
config openSUSE-11.4-i386/isolinux.cfg openSUSE-11.4-i386/
label openSUSE-11.4-x86_64
menu label openSUSE 11.4 x86_64
menu indent 2
config openSUSE-11.4-x86_64/isolinux.cfg openSUSE-11.4-x86_64/
label openSUSE-12.1-i386
menu label openSUSE 12.1 i386
menu indent 2
config openSUSE-12.1-i386/isolinux.cfg openSUSE-12.1-i386/

Here's a snippet of the openSUSE isolinux.cfg:

label linux
  kernel linux
  append initrd=initrd splash=silent showopts

Fedora (which works fine) looks like:

label linux
  menu label ^Install or upgrade Fedora
  menu default
  kernel vmlinuz
  append initrd=initrd.img quiet

Two weird things are happening.

  1. When I select openSUSE 12.1 i386, my tftp server shows an error like cannot access /var/ftpd/openSUSE-12.1-i386/../::openSUSE-12.1-x86_64/isolinux.cfg: Permission denied.
    • Where it's getting openSUSE-12.1-x86_64 is beyond me as I've removed all traces of it from my menu.
  2. The openSUSE menu appears to load just fine, but when selecting an option, it can't find the kernel file, kicking up tftp errors like file /var/ftpd/openSUSE-12.1-i386//::openSUSE-12.1-i386linux not found. I don't know where it got that path from.
    • Using URL-style paths like tftp://192.168.0.1/openSUSE-12.1-i386/ kicks up errors like file /var/ftpd/openSUSE-12.1-i386//tftp:/192.168.0.1/openSUSE-12.1-i386linux not found
    • Using paths like 192.168.0.1::openSUSE-12.1-i386/ kicks up errors like file /var/ftpd/openSUSE-12.1-i386//192.168.0.1::openSUSE-12.1-i386linux not found. Are there other path formats I could try?
    • Using the APPEND command instead of appending the path to CONFIG command results in the same behaviour

I know I'm trying to mix pxelinux and isolinux, but it looks like it should work. What am I doing wrong?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.