Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed Munin on a couple of our servers (CentOS) so I'll have some way to monitor what is going on.

[Sorry the images arn't embedded in, as it turns out new user's can't post images directly]

In one server it looks good with proper value-ranges: Good Graph Link

In others it looks like this: Bad Value Range Graph

Has anyone run into this ? I can't find any info on such an issue?

Thanks, Alon

share|improve this question
Could you telnet to one bad server and one good server on port 4949 (from the central munin server), do a config NAME-OF-PLUGIN, and edit the results in each case into your question above? – MadHatter Mar 28 '12 at 8:04
Cool I see that the one working well has this: graph_args -l 0 --base 1000 while the one that isn't working has this: graph_args --base 1000 --logarithmic – Alon Mar 28 '12 at 8:31
Will try to see how I can configure this – Alon Mar 28 '12 at 8:31
Maybe a bit of an awkward place to change this, either way I updated it directly in the plugin code in /etc/munin/plugins/netstat and it fixed it. Thanks for the help :) – Alon Mar 28 '12 at 8:36
Glad we fixed it. I've written my comment up as an answer, in the hope that you will see fit to accept it. – MadHatter Mar 28 '12 at 8:39

1 Answer 1

up vote 2 down vote accepted

If you telnet to a bad server and a good server on port 4949, from the central munin server, and do a config NAME-OF-PLUGIN, I expect that you'll see that the bad plugin passes graph_args --logarithmic and the good one doesn't. Fix the one that does, and you should stop getting log-lin graphs.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.