Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a laptop connecting wirelessly to an E4200 Linksys router. The router is configured to use DHCP with a range from #.#.#.100 to #.#.#.254. However, the laptop is being assigned an IP address of #.#.#.80 which is below the specified DHCP range. I'm not sure how this is even possible. Also, the laptop has Internet connectivity.

Out of curiosity I performed a ping -a on my laptop's assigned IP address from another client and it's showing a completely different host name.

Any ideas on why the laptop is being assigned an IP address out of the DHCP range specified in the router?

share|improve this question
1  
could you have another dhcp server running in your subnet? –  johnshen64 Mar 28 '12 at 19:28
    
Make sure you are not using a static address as well.. –  gparent Mar 28 '12 at 19:31
add comment

2 Answers 2

up vote 7 down vote accepted

Look at the ipconfig /all output. What is it showing as the DHCP server. Is it coming from the router/device you expect? Perhaps you have a rogue DHCP server somewhere.

share|improve this answer
1  
Precise answer. And correct IMO. –  Tim Mar 28 '12 at 19:35
6  
The problem isn't the laptop, it's the rogue DHCP server. –  David Schwartz Mar 28 '12 at 19:36
4  
You need to turn off the other DHCP server. You generally should never have two running on the same network unless you have performed special steps to setup clustering. Multiple DHCP servers on the same network causes badness. –  Zoredache Mar 28 '12 at 19:36
1  
@BryanRoth you can't choose which DHCP server your clients 'point to'. DHCP is a broadcast protocol - the clients shout out asking for an IP address and if a server responds, great. As others have pointed out, you need to turn off the unwanted DHCP service. –  Chris McKeown Mar 28 '12 at 20:55
1  
@BryanRoth If it's pointing to your DNS server then you know where your rogue DHCP server is :-) –  Sander Steffann Mar 29 '12 at 5:13
show 2 more comments

Your laptop probably had previously the #.#.#.80 address from a previous connection (it was connected elsewhere, or you just reconfigured your current router). After reboot, it asked to renew the ip address to the Linksys, which have the same ip address than the previous router. The answer was lost or something gone wrong, so your laptop kept its previous address.

You have internet connectivity because both LAN have same settings (same gateway, and same DNS which is usualy the gateway).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.