Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up Apache2 on a guest Ubuntu 10.04 OS (virtualbox).

I have created a "big" HTML file (4MB) with only plain text and when I access a page through my local IP address such as http://192.168.0.100 it successfully loads the entire page.

However, when I try to access it through my public IP address the browser loads part of the page and then hangs forever on "loading". I can load a simple webpage though.

I'm not sure whether it's an issue with my Apache configuration, Virtualbox, Router or Modem. Any clues?

Tried enabling Debug and mod_status but didn't find any useful information.

EDIT: that's sort of weird. I installed nginx and tried to load the same HTML page, same problem happens! So it looks more like a networking issue to me... :/

share|improve this question
    
What status code and content length are recorded in the Apache access log? –  Shane Madden Mar 29 '12 at 4:44
    
I dont know if that's what you mean, but here's what I have on access.log: [29/Mar/2012:10:46:54 -0300] "GET index2.html" 400 226 "-" "-" Additionally, I've saved the HTTP response (using telnet) and the response size is always approximately 4.2KB. –  Lucas Pottersky Mar 29 '12 at 13:48
    
Here's what I get when requesting with a browser: "GET /index2.html HTTP/1.1" 206 375 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11" "GET /index2.html HTTP/1.1" 206 12743 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.79 Safari/535.11" –  Lucas Pottersky Mar 29 '12 at 14:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.