Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Amavis is failing to do sql lookup when large number of emails are sent to amavis. Its throwing out error after scanning 40 to 50 email. It shows error like.

 (!!)TROUBLE in process_request: sql exec: err=7, 57P01,DBD::Pg::st bind_param failed:FATAL:  terminating connection due to administrator command\nSSL connection has been closed unexpectedly at (eval 103) line 164, <GEN50> line 5. at (eval 104) line 280, <GEN50> line 5.

As soon as this error appears in the logs, Amavis stops and port 10024 is closed. Thinking it to an error due to ssl connection in the database(postgresql-8.4), i had stopped ssl in postgres, but it was of no use. I have tried to configure amavis on another server, but i got the same error again.

This happening on a production server, So i am not being able to scan emails as per user settings. Anybody have any idea, what may be the source of this error ??

Please help. Thanks in advance

share|improve this question
    
This is an amavisd-new error about an SSL connection to a PostGres database; postfix or spamassassin are not involved. –  adaptr Mar 30 '12 at 11:12
    
@adaptr Thanks. I have tried without ssl. But amavis is showing same error without the word "SSl" in it. When i am sending few test mails to be scanned database lookup is working fine, but its showing this error when sending large numbers of mails at a time. Is it due to some memory problem with amavis.? Please suggest.. –  sandip Mar 31 '12 at 3:57
    
You should control the number of connections to the database; I don't know how you would do that from amavisd-new. –  adaptr Mar 31 '12 at 14:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.