Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have computer with 91.221.27.120, 91.221.27.119, 91.221.27.121 and 91.221.27.118. I set in postfix:

smtpd_client_restrictions =
    permit_mynetworks,
    warn_if_reject reject_unknown_client,
    warn_if_reject check_client_access hash:/etc/postfix/access,
    permit_sasl_authenticated,
    permit

When I add reject_unknown_client I get ONLY for 91.221.27.118

Mar 29 09:45:31 fo-mail postfix/smtpd[6132]: NOQUEUE: reject_warning: RCPT from
unknown[91.221.27.118]: 450 4.7.1 Client host rejected: cannot find your hostname, 
[91.221.27.118]; from=<x@mydomain.pl> to=<y@mydomain.pl> proto=ESMTP 
helo=<[172.16.210.24]>

I writed to access

91.221.27.118 OK 

It doesn't help.

Can you help me?

share|improve this question
    
what is setting of smtpd_delay_reject and what version of Postfix you are using? –  Dada Mar 29 '12 at 9:35

1 Answer 1

up vote 1 down vote accepted

rules in smtpd_client_restriction are checked in the same order as it written in the configuration directive. In your example, restrictive rule for reject_unknown_client is evaluating before permissive check_client_access. Try to change the order of those two directives. And, of course, you should have all your clients' IP's in access.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.