Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have just deployed SBS 2008 Standard and am able to do DNS Queries against the internal DNS Server, however, none of the clients are able to collect a response.

I have checked the Firewall configuration, and DNS is allowed through, and I checked the DNS Configurations as best I could.

I can't test with domain-joined PC's as this is a new deploy and I can't access http://connect.

Other services work, I set up remote Workplace access and tested it and RDP earlier from a remote location. Also, Exchange is able to send / receive mail.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Try restarting the DNS Server or just flushing the DNS cache. I have one 2008 server where after a few days it stops resolving any but local domain names. Just clearing the cache immediately fixes it. I still haven't worked out what is causing it.

JR

PS on rereading your question, do you mean the clients can't resolve any names, even internal ones?

Re alxconn's comment: first thanks, you've answered my question about DNS that I hadn't even asked yet! If anyone else finds their W2k8 DNS stops resolving external domains see http://support.microsoft.com/kb/968372.

Back to your question: the obvious first step is to turn off the firewall. If that still doesn't fix it download the network monitor v3.3 from www.microsoft.com/downloads and sniff a DNS query from a client to see what the server receives and what it replies. The DNS query protocol is pretty straightforward. Have you tried using nslookup and explicitely setting the DNS server using "server "?

share|improve this answer
    
Correct, the server will never respond to any client, even with internal domain names. The DNS Server stopping is actually a known bug with Server 2008 using Root Hints, changing to forwarders will fix it for you. (FYI) –  codatory Jul 8 '09 at 12:23
    
See my edits: you have at least solved my DNS problem! –  John Rennie Jul 8 '09 at 13:20
    
Well, after double checking the firewall (and making no changes) DNS is now working correctly; imagine that? –  codatory Jul 8 '09 at 13:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.