Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to create some custom event logs on my production domain controller by using sddl and sceregvl.inf (from %windir%\inf directory). The problem is that when i try to save the edited file i get the windows file protection error which doesn't allow me to save the file. Is there a way to disable it and then re-enable it?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Why not create the eventlog through powershell ?

new-eventlog -logname "My eventlog name" -Source "My eventlog source" 
share|improve this answer
    
The event log already exists, i'm trying to add the custom event log object in the local group policy, to be able to control the permissions on the log. –  Itai Ganot Apr 2 '12 at 22:52

whatever you're doing right now, you probably just need to "run as administrator" So if you're using computer managment, hold shift, right click computer managment and then select run as administrator. I'm pretty sure that'll do the trick.

Edit:

Check out this MS article, it's the sort of the same thing I'm saying. Whatever is doing the saving, needs to be running as the local administrator. Its eaither that, or you need to disable UAC. http://support.microsoft.com/kb/923947

share|improve this answer
    
Thanks for your answer, I've already tried run as administrator, more than that i've also tried runas /user:domain\user with domain admin permissions but it still doesn't allow me to save the file in the INF folder. –  Itai Ganot Mar 29 '12 at 18:11
    
see my edit above –  Eric C. Singer Mar 30 '12 at 1:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.