Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm setting up proftpd on an ec2 Instance running Ubuntu 10.04

I've gone through all the forums and tried every suggestion but still can't seem to get it working. I know the problem is with the passive ports but everything I've tried has failed.

The filezilla log shows:

Status: Resolving address of ec2-50-110-20-81.us-west-2.compute.amazonaws.com
Status: Connecting to 50.110.20.81:21...
Status: Connection established, waiting for welcome message...
Response:   220 ProFTPD 1.3.2c Server (Michaels Main) [50.110.20.81]
Command:    USER cube
Response:   331 Password required for cube
Command:    PASS *******
Response:   230 User cube logged in
Command:    OPTS UTF8 ON
Response:   200 UTF8 set to on
Status: Connected
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/home/cube" is the current directory
Command:    TYPE I
Response:   200 Type set to I
Command:    PASV
Error:  Disconnected from server: ECONNABORTED - Connection aborted
Error:  Failed to retrieve directory listing

In my proftpd.conf file I have the following lines for setting up the passive ports:

ServerType                      inetd
PassivePorts                    60000 60200
MasqueradeAddress               51.110.20.81

My iptables -L -v looks like this:

4475 370K ACCEPT all -- any any anywhere anywhere state RELATED,ESTABLISHED
   0    0 ACCEPT tcp -- any any anywhere anywhere tcp dpt:ftp-data
  13  676 ACCEPT tcp -- any any anywhere anywhere tcp dpt:ftp
   1   40 ACCEPT tcp -- any any anywhere anywhere tcp dpts:60000:60200
   0    0 ACCEPT tcp -- any any anywhere anywhere tcp dpt:ssh

netstat --vatn:

tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN
tcp        0      0 10.252.45.220:22        214.11.175.64:18169     ESTABLISHED
tcp6       0      0 :::22                   :::*                    LISTEN

/proc/sys/net/ipv4/ip_forward is set to 1.

I've uncommented the net.ipv4.ip_forward=1 line in /etc/sysctl.conf

This has my head fried, any ideas? If I've left anything out please let me know.

Thanks for your help, cheers!

share|improve this question
    
This is EC2, so did you set up the Security Group for this instance to allow the passive port traffic? –  cjc Mar 29 '12 at 19:42
    
Ports 60000 - 60200 are open in my Security Group –  Depmadra Mar 29 '12 at 22:19

1 Answer 1

Did you open ports 60000 to 60200 in your EC2 security group ?

share|improve this answer
    
Ports 60000 to 60200 are open in my ec2 security group. Thanks for the suggestion though. –  Depmadra Mar 29 '12 at 19:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.