Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a custom server in C# being run on Ubuntu 9 under mono. I can make up to 15 silverlight clients connect to the server. When I make the 16th, it just waits. And if I close one of the established connections, the 16th client is able to connect. I am making the connections from one machine. I am also not exceeding any file handle limit. The limit is 1024 and I am having around 300.

Any ideas how to make more connections? Also why the number 15? Is it something linux-specific?

share|improve this question
    
It seems likely that the problem is within your application, or mono. Have you considered trying something like having more then 15 systems SSH or open some other long-lived connection into the Linux box? Have you ruled out any restrictions by your ISP, or within your firweall? –  Zoredache Mar 29 '12 at 22:03
    
@Zoredache I have tried with 20 SSH connections and it works fine. –  gtan Mar 29 '12 at 22:18
add comment

2 Answers

I've seen a similar problem before - in that instance, a firewall had been setup on the server OS and it was throttling incoming connections to a maximum of 10 concurrent events.

Running sudo iptables -L and looking at the output (for text like 'limit', or just 15) might at least take such firewall throttling off the list of things to check. If there's a lot of output, then it's something to examine more closely as there will quite possibly be a system in place to generate a more complex set of rules. Adding such throttles can be quite common among such automated tools.

share|improve this answer
    
iptables -L produces the following: Chain INPUT (policy ACCEPT) target prot opt source destination Chain FORWARD (policy ACCEPT) target prot opt source destination Chain OUTPUT (policy ACCEPT) target prot opt source destination –  gtan Mar 29 '12 at 22:13
    
so, it's not being used. It doesn't appear to be any firewall then from the local machine. –  Alister Bulman Mar 29 '12 at 22:17
add comment
up vote 0 down vote accepted

I was using mono 2.6.7. Upgrading to 2.10.8 solves the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.