Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to setup a LAMP stack to use as a web development server and it's proving to be very frustrating for a novice like myself.

On a Fedora 16 machine, I've got Apache, MySQL, PHP, cURL, & Bind DNS installed and configured (though probably not quite correctly.) I've managed to get my CMS installed and working for a test site. That tells me Apache, PHP, & MySQL are working correctly.

However I'm running into a problem where the CMS used cURL to access an update server to do automatic updates as well as some other things (auto-installing add-ons.) WHen I try to enable this, I get an error that tells me to check that my server is running cURL (phpinfo tells me it is) and that allow_url_fopen is set to "On" (also true) and otherwise check with my web host to make sure outgoing connections for cURL are allowed.

Since I am the web host, I cannot seem to find the port I need to open up or settings I need to adjust to allow outgoing connections or even how to check what the current settings are. How do I check/allow outgoing connections for cURL?

share|improve this question
    
Is the php-curl package installed? –  pkhamre Mar 30 '12 at 6:34
    
I thought it was but I cannot find out. It seems that Webmin really messed up my machine. I cannot run any yum install commands from command line. I removed Webmin and I still cannot install anything from command line. It always say cannot resolve host. I can remove packages but there seems to be an issue in connecting to the yum repository. –  jlego Mar 30 '12 at 13:50
    
@pkhamre after solving the yum issue I confirm that php-curl is installed. When I run yum install php-curl it tells me the php-common package is already installed. –  jlego Mar 30 '12 at 21:15
    
Check your iptables setup (iptables -L) for http and dns. Also check your server is resolving names correctly. –  symcbean Apr 3 '12 at 10:03

1 Answer 1

up vote 1 down vote accepted

Assuming you can SSH into your development machine, try to e.g. telnet to the update host, or to www.google.com port 80.

telnet www.google.com 80

If that works, you will at least know you have access to the outside world. cURL then should have access to the outside world as well. Are you perhaps using a proxy to reach the internet? In that case, you will have to tell cURL about the proxy host and port. Are you doing any local firewalling on the development machine? Then make sure you allow outgoing traffic.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.