Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just want to setup a system wide environment variable, JAVA_HOME for all users, including root user.


  • accessible to normal users
  • accessible to root
  • always loaded, not only for bash (gnome-terminal does not start a bash by default)
  • to work on Ubuntu, Debian and optionally Red Hat
  • great if addition could be easily scripted
share|improve this question
up vote 13 down vote accepted

As nobody added a full answer here is what I currently consider the best, at least for ubuntu but I am open to adapt the answer for other *nix platforms.

# **create**: /etc/profile.d/
export JAVA_HOME=/usr/lib/jvm/default-java

Other options that were already considered but ruled out:

  • /etc/environment works but is harder to maintain as other tools or people can edit it.
  • /etc/profile - same as above
share|improve this answer

On Debian/Ubuntu that would be /etc/environment

I don't know the Red Hat equivalent.

share|improve this answer
I believe /etc/environment is deprecated – Pat James Nov 25 '12 at 19:17
@PatJames do you have more info about this? I tried /etc/environment is is not loaded for root even after I rebooted the machine. – sorin Oct 30 '13 at 11:18
@SorinSbarnea some info is here: indicating /etc/environment is no longer used in newer releases – Pat James Oct 30 '13 at 17:52
That page only says that you shouldn't but locale related variables in /etc/environment. See also – Flow Jul 30 '14 at 14:42

I don't understand why you ruled out /etc/profile. That is the correct location.

share|improve this answer

A few have answered saying that /etc/environment is depricated and/or not used in Debian anymore, and this is (as at version 7) false.

The file is actually read by PAM -- specifically, pam_env(8), via a default to the envfile flag. The manpage also states this default under the FILES section.

The wikis quoted (especially the locale one) merely state that locale-based environment variables are now meant to be in /etc/profile. Their statement "(in older versions of Debian, also /etc/environment)" is vague, and is in the context of locales.

A quick grep through /etc/pam.d shows:

root@box:/etc/pam.d# grep *
atd:auth        required
cron:session       required
cron:session       required envfile=/etc/default/locale
login:session       required readenv=1
login:session       required readenv=1 envfile=/etc/default/locale
sshd:auth       required # [1]
sshd:auth       required envfile=/etc/default/locale
su:session       required readenv=1
su:session       required readenv=1 envfile=/etc/default/locale

Those config lines are additive, and as the first is missing envfile, it thus defaults to /etc/environment.

All of this, of course, relies on whatever binary you're using (crond, login shells etc) are compiled against PAM.

Finally, this implies that other systems using PAM (eg RedHat), behave the same, as can be seen in it's respective manpage.

share|improve this answer

One a side note: Have a look at the Modules Environment. I use this every time I have to offer a complex, versioned, self-extensible, concise UNIX environment to dozens or hundreds of users. It's mainly used on large scale multi-user HPC environments. Just using it for one particular variable is certainly over-engineering it, but it does an awesome job once you need more than a few software packages and their environment.

share|improve this answer

/etc/profile should work. I tested just now to be sure, put export SOMETEST=1234 to /etc/profile and after re-logging echo $SOMETEST gave me 1234 as expected. Also from gnome-terminal

share|improve this answer

/etc/enviroment is no used in the last debian stable release. The recomendation is create your own *.sh file in /etc/profile.d/ for this porpuose as Sorin S saids. See

share|improve this answer

You cannot use any ~ specific files in this case. so....

/etc/profile would be the proper place for it in this case. Current logged in users have to get a new login session though, but this should not be that big of a problem.

@wk01: /etc/profile is not loaded by a nonlogin shell by default. your .bashrc is probably loading it...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.