Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've been trying to install OpenIndiana on an HP DL320 G6 for a while now. I've got a 16GB HP SDHC card in the onboard slot and a SATA CD-Rom with oi-dev-151a-text-x86.iso burnt to a disc.

Installation seems to progress fine until I get to the actual installation portion. The SD card is picked up as a USB Disk. All the other configuration options are very 'normal' (there really aren't many options to begin with). Automatic NIC configuration.

The installer starts "Installing OpenIndiana", does a few steps, then gets to "Preparing disk for OpenIndiana installation" at 2%; and just sits there. I've let it sit for half an hour now ans still no progress.

How can I get past this issue?

PS> I'm not terribly familiar with OpenSolaris, but am with FreeBSD and *nix CLIs in general.

Update 1:
I've download and burnt the graphical installer (wow, it does not work with iLO). After finding a keyboard, mouse, etc I got the installer going. Stops in the same place, but now with the error: Cannot mount volume: Unable to mount the volume 'rpool1'. and and OK button. It appears the installer has no exception handling, as clicking OK results the installer hanging (the ads still rotate and the computer is otherwise responsive, but the installer does not progress).

share|improve this question
    
can you try the live usb boot version as a quick test. openindiana.org/download –  tony roth Mar 30 '12 at 16:06
1  
I have been repeatedly unsuccessful installing Solaris (Express) 11 on USB storage in different hardware setups with rather similar symptoms - the storage seemed pathetically slow and functions did time out during installation. It might have been a problem with a certain kind of USB controller. Not having the time for digging into it, I reverted to using SATA SSDs. –  the-wabbit Mar 30 '12 at 16:44
    
@tonyroth Done, gave some hints as to what's going on, I guess.. –  Chris S Mar 30 '12 at 18:13
    
can you disable the on board sas controller, then retry? –  tony roth Mar 30 '12 at 18:41
1  
Follow-Up: To anybody wondering, I gave up on getting OI to work. I sunk too many hours into it given it's cryptic error messages and horrid exception handling (or lack thereof). I found an article on setting up SmartOS (another OpenSolaris derivative by Joyent, aimed at being a "Cloud" platform, which is essentially what I'm looking for); and it was easier to hack that into place. –  Chris S Apr 3 '12 at 17:50

1 Answer 1

I experienced this very same issue with a special request to have a service provider install Nexenta on their storage platform.

The problem is OpenSolaris/OpenIndiana generally only runs on older hardware because it forked a long time ago and there is a limited selection of drivers. A newer version of Solaris may still not help because the same issue of a limited selection of drivers. Even if it would seem to install, it may still be flakey later on because the drivers were never Q/A'ed on that exact model, revision and firmware of hardware (but it may also work out of luck). This is why using something known to work on the vendor's HCL avoids lots of pain and very expensive wasted time / surprises later.

For non-production use, I highly recommend going over to your local server repo place like UnixSurplus and picking up a cheap Sun intel box that ran effectively the same Solaris codebase that you'd prefer to use.

share|improve this answer
1  
SmartOS (derived from OI) runs just fine, it's a bug in the installer and not drivers. But this is generally good advice. Thanks anyway! –  Chris S Oct 7 '12 at 20:30
    
Might want to mark this as solved. –  Barry Oct 8 '12 at 13:12
    
Sorry to come back a year later, just want to specifically mention that the DL320 G6 is on OpenIndiana's the HCL. So your whole answer has nothing to do with the question... –  Chris S Oct 29 '13 at 14:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.