Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Windows Server 2008 R2, with IIS 7.5 and PHP 5.3 (configured by FastCGI). In my php.ini I have:

log_errors = On
display_errors = Off
error_log = syslog      (also tried an actual file with appropriate permissions)

Each time a page contains an error, it is never logged anywhere, but it is displayed on the page (unless I turn log_errors off). I'm guessing that the stderr from php-cgi.exe is being put on the page, instead of being logged where it is supposed to be. Is there a setting somewhere that allows me to log these errors properly?

share|improve this question

1 Answer 1

I removed the PHP 5.3 installation and instead chose to install PHP 5.4 manually using the zip file rather than using the MSI installer. From there, the same configuration as mentioned in the question allowed PHP to log correctly. Perhaps it was a version mismatch or something.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.