Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I load my my.conf with the config at the bottom Mysql fails to start and prints no errors. I am running Arch Linux (Updated) with the latest MySQL (5.5) and the latest nginx (Well latest in the repository, Not sure how to check. Only installed it today)

I will give you any info you ask for. Thanks for helping!

 # The following options will be passed to all MySQL clients
[client]
#password       = your_password
port     = 3306
socket   = /var/run/mysqld/mysqld.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port     = 3306
socket   = /var/run/mysqld/mysqld.sock
skip-locking
key_buffer = 16K
max_allowed_packet = 1M
table_cache = 4
sort_buffer_size = 64K
read_buffer_size = 256K
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 64K

# Don’t listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (using the “enable-named-pipe” option) will render mysqld useless!
#
#skip-networking
server-id       = 1

# Uncomment the following if you want to log updates
#log-bin=mysql-bin

# Uncomment the following if you are NOT using BDB tables
skip-bdb

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 – 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 16M
#innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 5M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50
skip-innodb
[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 1M
sort_buffer_size = 1M

[myisamchk]
key_buffer = 1M
sort_buffer_size = 1M

[mysqlhotcopy]
interactive-timeout

So what is my silly error?

share|improve this question

migrated from webmasters.stackexchange.com Mar 31 '12 at 12:15

This question came from our site for pro webmasters.

    
Have you tried the MySQL daemon cannot start troubleshooting instructions at the Arch Wiki? –  danlefree Mar 31 '12 at 11:23
    
You will find loads of extra information in your syslog. /var/log/syslog –  Antoine Benkemoun Mar 31 '12 at 12:20
    
Only 5.1.20 writes logs via syslogd by default, and all later versions use plain file as before, due to the serious performance problems. At least, that mentioned in the mysql documentation. –  Kondybas Mar 31 '12 at 14:15

1 Answer 1

up vote 3 down vote accepted

Mysqld writes log into %BASEDIR%/%HOSTNAME%.err In my cases this is /var/db/mysql/lab.home.lan.err Look in it for hints about failures.

share|improve this answer
    
Okay. My options in the config are giving it errors. Sorting it out now Thanks! –  Knight Hawk3 Mar 31 '12 at 21:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.