Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get a Symfony2 standard distribution to work on my Windows 7 laptop.

I have installed Apache2 (version 2.2.22), PHP 5.3.10 and MySQL 5.5.22.

I have a demo PHP script (php_info() and a database call), and it works fine.

I can get the start page (http://localhost/Symfony/web/config.php) to display, but I cannot get http://localhost/Symfony/web/app_dev.php/ to execute.

The error returned is Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.

I can get it to work if I install XAMPP instead, but I don't want to use XAMPP. I want to be able to install and configure the components separately.

Why isn't this working?

Are there some Apache settings that I am missing?

share|improve this question
up vote 1 down vote accepted

This is a super strange bug:

TL;DR Your git is converting line endings to CRLF on pull, which makes the vendors file TwigEngine.php exactly 4096 bytes which crashes PHP on include/require.

The workaround is to remove your vendors (or just symfony). Set your git config to not convert line endings:

git config --global core.autocrlf input

And install vendors.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.