Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm reconfiguring roaming profiles on my network to use proper NTFS security settings according to this article. I have reset the following permissions on the roaming profile parent folder:

  • CREATOR OWNER, Full Control, Subfolder and files only
  • User group with profiles, List folder, Create folders, This folder only
  • System, Full Control, This folder, subfolders, and files

Then I select one of the actual roaming profile folders and follow these steps to fix the NTFS settings:

  • Click Security, Advanced
  • Uncheck "Allow inheritable permissions..."
  • Choose "Remove..."
  • Recheck "Allow inheritable permissions..."
  • Click "Apply"

After I choose apply, I get the following permissions listed on the roaming profile folder:

  • Administrators (MYDOMAIN\Administrators) Full Control, This folder only
  • CREATOR OWNER, Full Control, Subfolders and files only
  • System, Full Control, This folder, subfolders, and files

Where is the Administrators entry coming from!? There is an entry on the root of the drive for Administrators to have full control, but the Roaming Profile Parent folder is not set to inherit any permissions, and it does not have the administrators permission.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

It appears the problem was coming from my misunderstanding of the "CREATOR OWNER" permission. This "account" does not map to an SID, rather it is a permission that tells the OS "when a new item is created in this folder, grant these permissions to the creator/owner". Because I was creating the account with an administrators user, it caused the permissions to follow.

share|improve this answer

The administrator rights might come from one of the below:

  • Group Policy that give domain admin rights :)
  • Default Windows rights (NTFS folder rights set to administrators)
  • From the folder on the server where the roaming profile is set, so it applies the settings from there.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.