Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am having problem that mail sent out from my server all goes to recipient's spam folder.

I am running Drupal sites on Linux server. CentOS w/ cPanel.

Our users cannot receive email as the mail went to the spam folder. (such as registration email, contact form email)

I was advised that I need to have PTR/rDNS record added for my host.

I then contact my datacenter to add PTR/rDNS thing, unfortunately, the datacenter said they are unable to do it.

So what can I do? Any other ways I can fix the problem?

Thank you!

*update, provided a screenshot from gmail spam folder

enter image description here

share|improve this question
Why are the datacenter unable to do it? Do they own the IP address space that you have been allocated? –  Chris McKeown Apr 2 '12 at 11:35
1. the netblock owner, which may not be the datacenter, needs to add/create the PTR record. 2. How do you know that the lack of a PTR record is the cause of your problem? Do you have logs or have you had communication with the email administrator of the recipient domain that confirms that the lack of a PTR record is the reason the email is being flagged as spam? –  joeqwerty Apr 2 '12 at 11:44
@joeqwerty I've seen it too, gmail doesn't like IP's that do not hold a PTR record. –  Lucas Kauffman Apr 2 '12 at 11:50
@ChrisMcK they don't tell me why, I was mad at them in the phone, not matter how, they just told me that they simply unable to do so. ya, I know, it's a really bad datacenter. –  gilzero Apr 2 '12 at 11:50
@gilzero explain the problem, if they still don't allow it consider changing DC. –  Lucas Kauffman Apr 2 '12 at 11:51

4 Answers 4

up vote 10 down vote accepted

Get yourself a better hosting provider. There is no reason whatsoever that a facility that is worth paying cannot create appropriate reverse DNS entries.

Now, whether that's the cause of your e-mail being flagged as spam, well, you haven't really given enough to go on, but I'd consider it fairly unlikely that your mail is being widely detected as being spam unless what you're sending smells like spam for a number of other reasons, such as:

  1. The rDNS is actively wrong (as in, it doesn't round trip correctly -- rDNS points to name, name doesn't point to IP -- in which case, the idea that the hosting provider can't change rDNS is clearly wrong, because they've done it already); or
  2. The IP address you're sending from has a poor reputation from prior abusive customers. In this case, again, your hosting provider isn't worth feeding, because they clearly have no problems hosting spammers (and hence you're supporting spam by giving them your money).
share|improve this answer
thank you for your answer. ya, switching hosting provider is the last move to adopt if there is no other solution, as we are kind of reluctant to moving server at this stage. thanks for the possible reason. upvoted –  gilzero Apr 2 '12 at 11:55
+1. These guys suck, ditch 'em if you can. Never worked with a paid hosting that wouldn't update PTR records for me. –  Kyle Smith Apr 2 '12 at 11:58
+1. The root cause of this specific issue may be unrelated to rDNS. Nevertheless, it's definitely something that should be offered by the hosting provider. –  Mike B Apr 3 '12 at 17:46

In addition to womble's answer and the comments.

If they still refuse to do add the records:

  • change DC
  • if one isn't possible, rent a server elsewhere from which you handle all the email (make sure they allow setting PTR records though).
share|improve this answer

That blurred-out email address looks a bit like it ends in "". Two of the error messages from Gmail suggest that you are trying to send email from your own server with a From: address that matches your own Gmail account. To do this and not be sent to the spam folder, you would have to get Google to put your server's IP address in their SPF record. This is unlikely to happen.

The middle error message is common when you are manually creating emails by hand and haven't quite got the headers and/or the format correct.

It's unlikely that your host will want to set their rDNS to and even if they did, you would still get sent to the spam folder because your IP address is not listed in Gmail's SPF record.

Feel free to correct me if I've squinted at that address improperly.

share|improve this answer

First you should be totally sure why the email went to SPAM folder.

PTR record would be really important but it is not the most important one.

However in the meantime try to set up a SPF record for your domain, this may help a bit. -

Also you could use an external provider to send messages, and they could set up everything for you. Examples are Amazon SNS, Sendgrid,

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.