Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to uninstall plesk from my VPS by running following command:

yum remove sw-* psa-* plesk-*

When I run this command I get following error:

Running rpm_check_debug
Running Transaction Test
memory alloc (4 bytes) returned NULL.

First time when I run above command, this mem alloc (4 bytes) was very big number like (67864987). then I Googled it, got some clear/ulimit commands. Executed them. Rebooted my system. Stopped all processes and executed this command again but still getting 4 byte issue. Don't know how to get rid of it.

I also tried ulimit after reboot but no success and Yes. No swap attached. These are stats of my system:

[root@vps ~]# free -m
             total       used       free     shared    buffers     cached
Mem:           384         67        316          0          0          0
-/+ buffers/cache:         67        316
Swap:            0          0          0

top - 21:01:07 up  3:12,  1 user,  load average: 0.24, 0.08, 0.03
Tasks:  31 total,   2 running,  29 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    393216k total,    69832k used,   323384k free,        0k buffers
Swap:        0k total,        0k used,        0k free,        0k cached

Is there any other alternative to achieve my goal to uninstall plesk? thanks.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Rebooting your system undoes everything you set with ulimit - Raising the limits is effective for the current session only.

Absent more information about your configuration we can't help you, we can only take wild guesses in the dark.
My wild guess: Your VPS does not have sufficient RAM allocated to it to run the yum/rpm removal process, and probably doesn't have any swap configured.
Either:

  • Remove the packages one or two at a time (which may or may not solve the problem)
  • Have your provider allocate more RAM to your VPS (and pay them accordingly)
share|improve this answer
    
Yes. You are right. my VPS didn't have sufficient memory for this process. so i left using that system. –  Kashif Apr 30 '12 at 13:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.