Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On Windows 2003 you could choose between:

  • Minimize memory used
  • Balance
  • Maximize data throughput for file sharing
  • Maximize data throughput for network applications

These options used to be found under:

Control Panel -> 
    Network Connections -> 
       NIC Properties ->
           File and Printer Sharing for Microsoft Networks ->
               Server Optimization tab

On Windows 2008 Server it appears you can't set this property any more. Do I set this somewhere else, or, are these options no longer valid under Windows 2008?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Seems that this option has disappeared from the user interface. But it is still available as registry setting (Microsoft Technet documentation):

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management 
DWORD: LargeSystemCache

and

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
DWORD: Size

I'm not sure if changing the default values will have an effect on the system.

Description

Specifies whether the system maintains a standard size or a large size file system cache, and influences how often the system writes changed pages to disk.

Increasing the size of the file system cache generally improves server performance, but it reduces the physical memory space available to applications and services. Similarly, writing system data less frequently minimizes use of the disk subsystem, but the changed pages occupy memory that might otherwise be used by applications.

Option setting                   Large System Cache value  Size value
---------------------------------------------------------------------
Minimize memory used                                    0           1
Balance                                                 0           2
Max throughput for file sharing                         1           3
Max throughput for network app                          0           3
share|improve this answer
    
Appreciated. You could maybe add the name of the DWORD: LargeSystemCache and this key: HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters, DWORD:Size to your answer then it's perfect. –  Kev Jul 8 '09 at 12:54
    
Oh, I forgot the 2nd registry key. Done! Thanks Kev. –  splattne Jul 8 '09 at 13:07

The Windows Server Performance team say that LargeSystemCache is ignored in Windows Server 2008. The Windows Vista/Server 2008 kernel was modified to adjust the amount of virtual memory (in the kernel address space) allocated to each task dynamically, depending on the workload. That article states that the Memory Management registry settings were left in place for compatibility with applications that try to read the settings, but they have no effect.

It's not clear whether LanmanServer\Parameters\Size still has any effect. The MaxWorkItems value still has an effect for SMB 1.0 clients, but not for SMB 2.0, according to Citrix: SMB Tuning for XenApp and File Servers on Windows Server 2008.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.