Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to update it I get this error:

Transaction Check Error:
file /usr/lib64/libcurl.so.4 conflicts between attempted installs of curl-7.20.0-1.el5.x86_64 and libcurl-7.19.7-26.el6_2.4.x86_64
share|improve this question
1  
You need to decide if you're running EL5 or EL6. –  Ignacio Vazquez-Abrams Apr 2 '12 at 22:41

1 Answer 1

As Ignacio points out, there's some conflict between "el5" (Enterprise Linux 5, i.e. RHEL5) and "el6" packages here. You can double-check what version of CentOS you have in /etc/redhat-release or /etc/issue. The rpm that provided your installed /usr/lib64/libcurl.so.4 can be checked with:

rpm -qf rpm -qf /usr/lib64/libcurl.so.4

All this should hopefully point out that you really are running CentOS 6.2, and that libcurl.so.4 is from an "el6" variety of package.

Then the question is how your attempted update decided you needed something from el5. A standard first step might be to do:

yum clean all
yum update

and see if you get the same problem. If so, how about seeing if there are any installed packages with "el5" (maybe installed manually with rpm instead of with yum?):

rpm -qa |grep el5

Could be some need to be removed, and replaced with updated versions for CentOS 6.

share|improve this answer
    
Thanks for an actually helpful response. I will check it out and report back. –  qitch Apr 3 '12 at 0:28
    
When I do the yum update I end up getting this error: Error: Package: python-ethtool-0.6-2.el5.x86_64 (epel) Requires: python(abi) = 2.4 Installed: python-2.6.6-29.el6.x86_64 (@base) python(abi) = 2.6 Available: python26-2.6.5-6.el5.x86_64 (epel) python(abi) = 2.6 Available: python31-3.1.4-1.ius.el5.x86_64 (ius) python(abi) = 3.1 –  qitch Apr 3 '12 at 0:39
    
Looks like when you installed EPEL, you picked the wrong system and architecture... –  Charles Apr 3 '12 at 0:47
    
@Charles is there a way to fix this or should I just reinstall the OS? –  qitch Apr 3 '12 at 0:48
    
You're going to need to find and remove all packages you installed from EPEL, and the EPEL repo itself. The rpm command given by Lars is one way to find those packages. yum list installed | grep -i epel is another. –  Charles Apr 3 '12 at 1:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.