Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two DSL lines coming in to wireless access points and then running to a RV082 Gateway/Bridge. The gateway then runs to a switch, which runs to multiple PCs and a Printer (See picture below). Normally, I would set up the wireless access points behind the gateway, but they are also the modems for the dsl. I have found that I can not print to the network printer if I am connected to the wireless network, but only if I am connected to the wired network.

How can I configure the Gateway and APs (Routers) so that the PCs and Printer are all on the same internal network?

I have tried turning DHCP off or redirect on the APs and redirect them to the Gateway. However, neither of these worked. Furthermore, I tried pinging the Gateway from the AP but got no response.

enter image description here

share|improve this question
    
You have double NAT. The "modems" are actually routers, and the "bridge" is actually a router too. It's time to totally rethink the layout so that you're using two modems and one router. You have three LANs, for some reason. –  David Schwartz Apr 3 '12 at 6:05

2 Answers 2

I'm familiar with the RV082 and its dual WAN ports. I'm also familiar with DSL modems that have WAPs baked in. What is happening is that your WAPs are on an entirely separate subnet from your LAN.

You need to determing the subnet that the WAP(s) are using (192.168.1.0 and 192.168.2.0, for example), make a static route in the RV082 for those subnets and route traffic for those other subnets out the proper interface. Note that both WAPs are probably set to use the same subnet. Either give the WAPs different IPs on the same subnet or different subnet numbers.

Also note that it might be saner to disable the WAP transceivers and get a WAP to place on your LAN.

share|improve this answer

Ditch the wireless on the DSLs.

Get a real Wireless Access Point, preferably one for each band that your users will be operating on. Connecting an 802.11b will take your 802.11g down to 'b' mode.

If you really need the wireless units to offer DHCP, set aside a subset of the IPv4 addresses in your network to each WAP. The WAPs should have the default route set to your Gateway. Tell your DHCP server on the wired subnet to not offer IPs in the range set aside for the WAPs.

share|improve this answer
    
Okay, this is the real answer. My answer is the "what to do when the boss says no" one. =) –  Wesley Apr 3 '12 at 3:29
    
@WesleyDavid When the boss says no present them a list of potential failure points & problems. Insist on a signature acknowledging that they have had the problems explained and are insisting on the sub-optimal solution before implementing it Their Way. When it fails give a copy to the next level of management up and await either the promotion or the sack, depending on the company. (Typically if you get the sack you were being sacked for the failure anyway, but at least your point is made :-) –  voretaq7 Apr 3 '12 at 3:49
    
@voretaq7 Hark! Do I hear the steely intonations of experience? =) –  Wesley Apr 3 '12 at 3:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.