Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After an unsuccessful Virtualbox VDI drive resize following the instructions here, the primary ext4 partition became of unknown type.

I fixed this with testdisk and then boot-repair, which made it be recognized as ext4 but not boot. Instead, it is reported as having 95% free space while this figure should be of 5% instead (I have the pastebins of boot-repair before and after).

I can mount the partition with backup superblocks using sudo mount -o sb=131072 /dev/sdb1 /mnt/sdb1, but there is only a lost+found folder inside (using other superblocks doesn't change what is visible).

Therefore, as per these instructions and these, I tried to run sudo e2fsck -y -b 32768 /dev/sdb1 on it from within another Ubuntu 11.10 OS 64 bits with 4 GB or RAM and plenty of disk space, but it eats up all the RAM, part of the swap, and miserably aborts after around 30s saying:

Error storing directory block information (inode=115343515, block=0, num=108120142): Memory allocation failed
e2fsck: aborted

I tried specifying a scratch directory as per the man page and answers suggested here, here,here, here, and here, but nothing has helped thus far overcome the out of memory error.

Do you know of any alternative tool to fsck?

I am desperate not to be able to proceed with the file system repair just because of a memory issue... Given the pace at which it is eating up memory, I doubt having more would help at all.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.