Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed mod_pagespeed in Apache. It drops header X-UA-Compatible. When I turned of mod_pagespeed X-UA-Compatible appear in headers. Have anyone idea how to disable this in mod_pagespeed?

My .htaccess file:

<IfModule mod_headers.c>
  Header set X-UA-Compatible "IE=Edge,chrome=1"
</IfModule>

<IfModule mod_rewrite.c>
    Options -MultiViews

    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
</IfModule>

Thanks a lot!

share|improve this question
    
What is setting that header? –  Shane Madden Apr 3 '12 at 16:55
    
I'm setting it in my .htaccess file – see update in question. –  kuboslav Apr 10 '12 at 9:37
    
Just a shot in the dark, but try adding early to the end of the Header line? –  Shane Madden Apr 10 '12 at 15:31
add comment

1 Answer

I had the same kind of problem (Setcookie header was dropped by mod_pagespeed, which made sessions impossible to use).

In my case, it was caused by the flush() function in my PHP code.

Apparently mod_pagespeed only kept headers set AFTER the last flush, discarding all headers defined before :-/

Hope this can help...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.