Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

On windows Server 2008 R2 I have recently added the windows server backup (WSB) feature.

Opening WSB I get the message "Reading Data; please wait...". This message fails to go away, even after leaving the server for over 12 hours. I also notice in the task manager that svchost.exe (username: networkservice) is using all available processing power. So I terminated that process and then WSB comes on-line.

However after restarting the server and WSB the issue reoccurs. WSB also fails to recognize my store-in-go flash drive (2gb).

What is the underlying problem here?

share|improve this question
Can you provide more information ? Did you ever setup WSB to do backup ? What about if you remove this flash drive before launching WSB console ? what about event log errors? – Mathieu Chateau Apr 4 '12 at 15:27
@MathieuChateau, I have never setup WSB to do a backup. Removing the flash drive has no effect, the problem existed prior to us connecting the flash drive. The are no errors in the event log. – Reafidy Apr 6 '12 at 3:31
Have you tried running a backup with the WBADMIN command line tool to see if it completes successfully? Sometimes the GUI of Windows Server Backup can be the problem, but not the backup program itself. – user203253 Dec 21 '13 at 3:17

2 Answers 2

What fixed it for me : Run the backup software as administrator! That is, right click on the icon, and run as Admin. That is all it took to get it to work perfectly.

share|improve this answer

Do you have an iSCSI volume mounted? We mounted a NAS via iSCSI and ever since this is exactly what we see, when it was fine prior with a local partition only. Good grief! Even after WSB FINALLY Loads, good luck trying to launch the wizard to change a schedule or something. I wish I could solve this, as it's a major PiTA!

share|improve this answer
It is not a constructive answer. If you have questions to OP place them in comments. – Danila Ladner Dec 21 '13 at 4:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.