Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed WAMP through wampserver and am running it together with IIS on Windows 2008. When trying to open phpadmin, I get the above browser error.

Edit: the problem seems to be with Windows 2008. I can't connect to 127.0.0.1 at all. I've tried disabling ipv6 and disabling the firewall (just to test) and neither of those worked.

localhost is totally inaccessible to me.

share|improve this question

3 Answers 3

Ok, guys, the only thing that ended up working for me was to add listen 127.0.0.1:80 in the httpd.conf file. Thanks for all your help!

share|improve this answer

Have you taken a look at the C:\wamp\apps\phpmyadmin3.4.5\config.inc.php file? Try changing localhost to the IP you have apache listening on

$cfg['Servers'][$i]['verbose'] = 'localhost';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
share|improve this answer
    
Just tried it, didn't work. After digging around, it seems the problem is more comprehensive; I can't access 127.0.0.1 at all, and it seems to be a Server 2008 issue. I'm updating the question. –  Moshe Eichenthal Apr 4 '12 at 13:50
    
so from a cmd prompt you can't "ping 127.0.0.1" –  RomeNYRR Apr 4 '12 at 13:53
    
pinging 127.0.0.1 and localhost both do work. But in my browsers they wont connect... –  Moshe Eichenthal Apr 4 '12 at 14:08
    
Assuming this a dual-homed server using static IP's, attach another IP to the private NIC, (TCP/IPv4 advanced settings), change the config.inc.php file host setting and point it to the IP. restart all wamp services and try to reconnect using the new IP assigned to phpmyadmin –  RomeNYRR Apr 4 '12 at 14:28

I think you have a proxy set up in internet explorer, manually or through PAC. If not set up properly, internet explorer send traffic to proxy even for localhost.

from server, add Telnet client feature. Then try telnet 127.0.0.1 80 from a cmd. Blank screen must appear (ctrl + $ to quit)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.