Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a micro instance of a Ubuntu virtual server on my EC2. When I go to the terminal and ping Google is working, but when I go to the DNS address for my site, it doesn't work.

Public DNS:

This are my security group settings: enter image description here

What do I need to access the site?

share|improve this question
What do you mean by "access"? SSH? The web server? – cjc Apr 4 '12 at 13:49
@cjc hi thanks to see the site is live on my browser, – MaKo Apr 4 '12 at 13:50
so why the down vote? – MaKo Apr 4 '12 at 20:59
I didn't do it. Likely it was the lack of information/specificity. – cjc Apr 4 '12 at 21:00
up vote 4 down vote accepted

The stock Ubuntu images don't come with much installed. If you haven't installed a web server (Apache, nginx, etc.), nothing's going to respond when you visit the site in a browser.

If you have installed a web server, make sure it's running, and that you haven't installed some sort of software firewall that's blocking port 80.

share|improve this answer
oh of course!, I haven't installed any web server :p – MaKo Apr 4 '12 at 13:52
That'll do it. Heh. – ceejayoz Apr 4 '12 at 13:59
MaKo: Make sure to mark this as the answer when you get a chance. – Matt Simmons Apr 4 '12 at 14:59

The ping command is actually blocked by the firewall. It's not UDP or TCP protocol either, you need to add a rule to allow ICMP for your security group. Just enable all the rules for ICMP on all hosts.

That being said. It's not a good practice to enable ping as it opens your servers to attacks pretty easily. If you're just trying to see if the server is online you can connect to the server use SSH or RDP. Or you can enable ICMP for ONLY your ip if you really need to do so.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.