Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have installed a new Terminal Server running windows 2008 r2 enterprise OS, we have a watchguard which authenticates users on a SSO agent &* when the users try to go to a website and scroll down the page the website draws ever so slowly, We have tried to update the graphics card but the server is still very slow,

Is there anything else that we could do to try & resolve this issue? Any ideas would be really be appreciated

Server Specs are Below


Operating System: Windows Server 2008 R2 Enterprise 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506) Language: English (Regional Setting: English) System Manufacturer: HP System Model: ProLiant DL380 G6 BIOS: Default System BIOS Processor: Intel(R) Xeon(R) CPU X5550 @ 2.67GHz (16 CPUs), ~2.7GHz Memory: 24576MB RAM Available OS Memory: 24566MB RAM Page File: 9328MB used, 39801MB available Windows Dir: C:\Windows DirectX Version: DirectX 11 DX Setup Parameters: Not found User DPI Setting: Using System DPI System DPI Setting: 96 DPI (100 percent) DWM DPI Scaling: Disabled DxDiag Version: 6.01.7601.17514 32bit Unicode

share|improve this question
    
What about updating the network drivers? –  Bigbio2002 Apr 4 '12 at 16:46

1 Answer 1

What about clients ? Are they Windows 7 ? If so, check out RemoteFX feature from Microsoft: http://blogs.technet.com/b/virtualization/archive/2010/03/18/explaining-microsoft-remotefx.aspx

Also check :

  • On client rdp settings, that all feature are activated (100M connection profile),
  • Check on server network card speed & duplex (And on the switch that it's same, and full duplex in any case)
share|improve this answer
    
Some clients are using RDP from WinXP & Win7Pro, it disconnects them from time to time saying they've been disconnected & reconnects, –  James_91 Apr 4 '12 at 15:19
    
Also check for RDP settings, to be sure someone didn't set to disconnect inactive users –  Mathieu Chateau Apr 4 '12 at 15:21
    
netstat -e on the server and client to check for errors –  Mathieu Chateau Apr 4 '12 at 15:21
    
it only disconnects users who are inactive for over an hour but when they are word processing it kicks them & just normal use does this also, –  James_91 Apr 4 '12 at 15:24
    
Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved. E:\users\Administrator>netstat -e Interface Statistics Received Sent Bytes 1729316073 1964749163 Unicast packets 41583042 42319467 Non-unicast packets 474774 42552 Discards 15669 15669 Errors 0 0 Unknown protocols 0 –  James_91 Apr 4 '12 at 15:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.