Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used the VMWare VCenter Converter Standalone Client to convert a physical drive on my old PC to a virtual drive. The conversion worked fine and I ended up with a valid VMDK file. Next, I wanted to convert the VMDK to a VHD for use with Microsoft Virtual PC, since that's what I use on my new box. I used WinImage for the conversion and that worked fine, too. I can access the files from the virtual drive through WinImage.

However, when I create a new virtual machine using Virtual PC and add the existing VHD file, the machine doesn't boot. The initial boot screen flashes with the amount of RAM and then the screen goes black. If I turn off the VM and reboot in safe mode I can see the drivers being loaded until eventually it gets to crcdisk.sys and hangs indefinitely.

Any ideas how to fix this? I'm not opposed to starting over from scratch if there's another method to turn my physical machine into a Virtual PC VM.


EDIT - I should add that the virtual drive is a system boot drive and not a secondary drive.

EDIT - I tried booting from the install CD and doing a repair. The result was that the system could not be repaired due to a "driver error."

share|improve this question

If your old PC uses an EIDE (possibly also SATA) disk you can probably just snapshot it and restore the snapshot to a blank VM disk and the VM should boot. See for my favourite (free evaluation!) snapshot tool.


share|improve this answer

Make sure to use the latest version of the VMware converter tool, I believe that the current version is v4.03. I've always found that newer versions converted better. Stands to reason, I guess...

share|improve this answer

Most likely your boot device isn't configured properly in the registry to allow the system to boot.

share|improve this answer

Check the disk type under Vmware. It could have been converted to a Scsi disk - for which virtual PC doesn't have a driver. You may need to revirtualize the original disk but choose to convert it to an IDE disk.

If this is the cause, a simple repair of the install using the windows install disk should correct disk driver access problems.


share|improve this answer
It checked the disk type under VMWare - it is an IDE hard disk. – Rob Sobers Jul 8 '09 at 14:52
'fraid I don't have any other suggestions. I still think its driver related but the only option there is run through the os repair options from the boot CD. – Ian Murphy Jul 10 '09 at 13:30

Have you tried booting the VM with the Windows installation CD and running a repair on the OS that it finds?

share|improve this answer

This should solve your problem. Basically, even if your windows supports IDE drives, if it was installed on anything else, the IDE drivers aren't used. In order to set them up, you need to follow the article

share|improve this answer

have you used disk2vhd from sysinternals. The only real limitation is the os boot disk should be less then 128gigs!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.