Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed GlusterFS 3.2.6 on several servers running on CentOS 6.2. I don't have working hostnames, as it's a test setup, so I have just added the servers' IPs to the /etc/hosts file. The problem is that I cannot create a storage pool because of the DNS error:

[root@san ~]# gluster peer status
Number of Peers: 1
Hostname: example.com
State: Establishing Connection (Disconnected)

[root@san glusterfs]# tail -f /var/log/glusterfs/etc-glusterfs-glusterd.vol.log    
[2012-04-05 16:21:08] I [glusterd-handler.c:623:glusterd_handle_cli_probe] 0-glusterd: Received CLI probe req example.com 24007
[2012-04-05 16:21:08] I [glusterd-handler.c:391:glusterd_friend_find] 0-glusterd: Unable to find hostname: example.com
[2012-04-05 16:21:08] I [glusterd-handler.c:3427:glusterd_probe_begin] 0-glusterd: Unable to find peerinfo for host: example.com (24007)
[2012-04-05 16:21:08] I [glusterd-handler.c:3409:glusterd_friend_add] 0-glusterd: connect returned 0
[2012-04-05 16:21:08] E [socket.c:1685:socket_connect_finish] 0-management: connection to  failed (No route to host)

[root@san glusterfs]# grep dns /etc/nsswitch.conf
hosts:      files dns

[root@san glusterfs]# cat /etc/hosts
# It's not a real IP
192.168.0.1  example.com

[root@san glusterfs]# cat /etc/glusterfs/glusterd.vol 
volume management
    type mgmt/glusterd
    option working-directory /etc/glusterd
    option transport-type socket,rdma
    option transport.socket.keepalive-time 10
    option transport.socket.keepalive-interval 2
end-volume

I have also tried to connect directly with the IP address to avoid any DNS lookups but still not connected. Could you please help me to overcome this issue? Thank you.

share|improve this question
    
Re-built nodes with Ubuntu 10.10 and glusterfs 3.2.1 and everything's working from the box. –  Andrew Apr 6 '12 at 15:01

1 Answer 1

Maybe it's not a problem with DNS. Are you sure you have a properly configured iptables on the host you want to peer? Try to stop the firewall on the host, and check if it is a problem (I had the same issue and it turned out it is a firewall problem)

share|improve this answer
    
Thanks for your suggestion. Firewall is not the problem, I checked that. Anyway, I have already re-build my cluster. –  Andrew Apr 27 '12 at 7:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.