Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been able to remote desktop into my Windows Server 2008 R2 machine no problem. But then I installed a bunch of updates (including SP1) and now I can't RDP.

Some background info:

RDP is enabled (and Everyone is set to have connect permissions)

I have disabled the firewall with no luck.

I can ping the server no problem and can connect through all other normal means.

What could be causing this?

Edit: The port TCP 3389 is NOT LISTENING. Why would it be NOT LISTENING if the firewall is disabled??

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

I've been in a struggle with this same problem exactly today: a Windows Server 2008 R2 server was handling RDP fine, until someone installed SP1; then, all of a sudden, the Remote Desktop service started crashing on startup and/or on user connection. Looks like the problem was somewhat related to applying SP1 after the system had been up and running for a while... probably some pre-SP1 update is not compatible with SP1 itself.

Some suggestions:

  • Check that the "Remote Desktop" service is started. If it's not, start it.
  • Check that the "Software Protection" service is started, too. If it's not, start it.
  • Check the event log for an application crash related to the Remote Desktop service. If you find it, look at the version number of the referenced DLL(s). Chances are, it's 6.1.7600.X (RTM), instead of 6.1.7601.X (SP1). If this is the case, try replacing those files with the same ones from a working SP1-ed server.
  • If all else fails, uninstall SP1 and then re-install it; but this time, use the full installation package, do not apply SP1 through Windows Update.
share|improve this answer
    
Weird. I've done lots of server updates and the remote deskop always worked –  ADNow Apr 5 '12 at 20:40
1  
That was it!!! The Remote Desktop service WASN'T started and it was set to Manual. Funny, huh. Thanks!!!! –  Thomas Stringer Apr 5 '12 at 20:44
    
The same for me. I spent the whole day thinking "weird weird"... I still don't know what actually happened. But I know installing a SP via Windows Update is just asking for troubles. –  Massimo Apr 5 '12 at 20:45
add comment

As documented in the blog post here, I found the problem is due to hotfix 2667402.

I was able to solve the problem by logging into the affected server locally and running

wusa /uninstall /kb:2667402 /quiet /forcerestart

at a command prompt. After the server rebooted I was able to RDP to it again

share|improve this answer
add comment

From what OS are you trying to connect?

Check the remote desktop settings, is it the middle option?

enter image description here

share|improve this answer
    
The connecting OS is Win7, and yes that option is set. No luck. Any other ideas? –  Thomas Stringer Apr 5 '12 at 20:25
    
Any unusual events in Event logs? –  ADNow Apr 5 '12 at 20:25
    
Unfortunately no. –  Thomas Stringer Apr 5 '12 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.