Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install driftnet. I think I've installed all the dependencies per the website but when I run make I get the error below.

makedepend -- -g -Wall -I/usr/include/pcap -D_BSD_SOURCE `pkg-config --cflags gtk+-2.0` -DDRIFTNET_VERSION='"0.1.6"' `cat endianness` -- audio.c mpeghdr.c gif.c img.c jpeg.c png.c driftnet.c image.c display.c playaudio.c connection.c media.c util.c http.c
cat: endianness: No such file or directory
/bin/sh: makedepend: command not found
make: *** [depend] Error 127

What have I done wrong? Is there something similar but more current?

share|improve this question
add comment

3 Answers 3

Why not just install the driftnet RPM? You don't say what OS you are running so this assumes RHEL5 or equivalent.

Install Howto

Download the latest rpmforge-release rpm from

http://apt.sw.be/redhat/el5/en/x86_64/rpmforge/RPMS/

Install rpmforge-release rpm:

rpm -Uvh rpmforge-release*rpm

Install driftnet rpm package:

yum install driftnet
share|improve this answer
    
I'm running centos 6.2 I don't think its in the repo? No package driftnet* available. Error: Nothing to do –  Andrew Apr 6 '12 at 0:07
add comment

You don't have all the packages:

$ rpm -qf /usr/bin/makedepend
imake-1.0.2-3

So, yum install imake. I ran that on a CentOS 5 box, so the exact imake version may be different.

share|improve this answer
    
Thanks I made a bit more progress but now I have makedepend: warning: display.c (reading /usr/include/glib-2.0/glib/gstrfuncs.h, line 34): cannot find include file "stdarg.h" Thanks –  Andrew Apr 6 '12 at 0:08
    
That's part of the gcc package. –  cjc Apr 6 '12 at 0:28
    
Hmm. You might be short of "build essentials". Do a yum install gcc gcc-c++ kernel-devel. You may need to install other *-devel packages also. –  cjc Apr 6 '12 at 0:29
    
As per dmourati, you may also want to look at installing driftnet by package. rpmfind.net/linux/rpm2html/search.php?query=driftnet There doesn't appear to be RHEL6 version. You might be able to get away with a recent Fedora RPM. –  cjc Apr 6 '12 at 0:33
    
I've got the devel stuff installed. Did group install development tools thanksrpm -qa | grep gcc gcc-gfortran-4.4.6-3.el6.x86_64 libgcc-4.4.6-3.el6.x86_64 gcc-c++-4.4.6-3.el6.x86_64 gcc-4.4.6-3.el6.x86_64 –  Andrew Apr 6 '12 at 0:34
add comment

The makefile appears to be in transition. It creates an executable ./endian, which it uses to create endianness.h. The cat endianness looks like it isn't needed anymore. So I removed it from the Makefile and that let me proceed to my next problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.