Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Well, I have an ISP router in which I have configured DNS Servers to use (Primary & Secondary) like Google DNS. It works just fine.

But now I have setup a computer with DNS server (Simple DNS Plus). I got it working by settings my internal DNS Server IP Address in computer. i.e. 192.168.1.3

So, instead of settings my internal DNS IP Address in every computer in my network, I want to setup DNS Server into my router. So on every DHCP request, computer get DNS Server to use.

So I configured it like this:

Primary DNS: 192.168.1.3
Secondry DNS: (left blank)

After applying and DNS Requests stop resolving. But strange part is DNS request does goes to DNS Server but maybe not returned back, because all DNS request were available in cache logs.

I don't know why this is not working, let me know if you have any solution or wordaround for this.

Thanks!

Update 1:

NSLOOKUP Result

C:\Users\user>nslookup google.com
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  192.168.1.1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out
share|improve this question
    
What OS is your internal server running? –  DanBig Apr 6 '12 at 12:00
    
Its running Windows XP –  itgeek Apr 6 '12 at 12:04
    
Setting a client machine to use its own IP as primary DNS is not going to work. If this is not an Active Directory configuration, your client machine should either use your ISPs DNS (if they provide DNS lookup, some dont) or use another, like Google (8.8.8.8) or Level 3 (4.2.2.2). –  DanBig Apr 6 '12 at 12:08
    
Well, it is actually a Server installed with a DNS Server (Simple DNS Plus) and its works perfectly only if we setup DNS in every computer. But with using it with default gateway, it doesn't work. –  itgeek Apr 6 '12 at 12:15
add comment

1 Answer

up vote 1 down vote accepted

What's your Nslookup output? Have you setup your internal DNS server to forward requests it cant resolve to the router? Have you cleared your DNS resolver cache?

Edit

Login to the management interface of your modem/router and try to modify the Lan dhcp scope options for the dns server. if push comes to shove you can just connect your modem to your wireless router and control dhcp scope options (dns) from there. last case, manually assign your dns ip setting. this will work well for 1 or 2 pcs. anything over 5 will become a headache

share|improve this answer
    
I have updated question is nslookup result. Yes, I have set forwarding in DNS Server to Google DNS. Yes, I have cleared cache many times. –  itgeek Apr 6 '12 at 10:31
    
Now if I go into my DNS Server, this DNS request is made and DNS Server was able to resolve it successfully. –  itgeek Apr 6 '12 at 10:34
    
your client machine is using the gw instead of the DNS server. Change it manually to 192.168.1.3 to confirm it indeed works. what kind of router are you working with? –  RomeNYRR Apr 6 '12 at 10:40
    
To clear things its actually modem/router both provided by my ISP. Broadcom 96338L-2M-8M. One another thing, I think you're right about Gateway stuff, I tried same thing with a Wireless Router, again it doesn't work. But my wireless router have option to setup DNS with DHCP settings, with those it started working for wireless systems. –  itgeek Apr 6 '12 at 10:54
    
Hello there, have you figured out something? I am thinking of settings up DHCP Server on my DNS Server system and disable router DHCP, so now I will be able to setup DNS correctly. simpledns.com/kb.aspx?kbid=1216 –  itgeek Apr 6 '12 at 11:31
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.